Notifications
Clear all

Chord octave view.


stratblue
(@stratblue)
Member
Joined: 2 years ago
Posts: 67
Topic starter  

Hey Eric.

 

Thanks for implementing this feature, it has really opened up a lot of chords and stuff I wanted to do, all that stacked tracks stuff I was doing before was a real PITA. I noticed something weird though, I fired up the Octo straight after you sorted out my dodgy install and tested out the new feature and all was good. I had a long session yesterday and I swear I was doing the same thing but despite power cycles and loading old projects I couldn't get it to work. I have just sat down now again and it worked first time. I did the double click + hold on the chord button and when I added extra notes above the C base note all that happened was that the A# note toggled on and off and the polyphony changed correspondingly. I tried other notes as base and it seemed that the toggle note was always a tone below the step base. See the video link below. I have obviously made a stupid error somewhere but I really can't see where, when you have a moment, could you point it out?

 

https://www.youtube.com/watch?v=mc-4ktwKy7Y&feature=youtu.be

 

Thanks.


Quote
Jean Blanc
(@jean)
Member Admin
Joined: 2 years ago
Posts: 19
 

Hi Nick,

Can I ask if you cleared the memory after the upgrade - i.e. Reboot the machine whilst continuing to hold the CLR mutator ?

As with all firmware upgrades things get moved around in memory so without a 'clear-out !'  weird things can (and will) happen.

So if you didn't do it before, clear the memory then save that empty memory to flash - you can them load in your pages.

Oh, and bear in mind that there is a proviso in the release notes about earlier pages with chord spaced of more that one octave needing to be re-entered:-

"Chord v2.0 data structure is not fully backward compatible, you can import the chord
step from earlier versions and chord steps that contain notes only in octave 1 will be
unchanged.
However, if the chord step from earlier versions contains chord notes in higher
octaves, octave 2 and/or octave 3, then the chord will have to be re-entered as its
notes will have been changed(& notes added) in the upgrade process."

 

Do let me know if this resolves the issue.

Best,

Jean


ReplyQuote
stratblue
(@stratblue)
Member
Joined: 2 years ago
Posts: 67
Topic starter  

Hey Jean.

 

I have started the Octo up whilst holding the Clr button but haven't saved that to the memory that I can recall, all though I will have started up the Octo as I mentioned, done some work and then saved that. I have done as you suggest now. Will let you know about any.....'weirdness'.


ReplyQuote
Eric
 Eric
(@eellis)
Member Admin
Joined: 2 years ago
Posts: 46
 

I wanna mention that this feature was developed by Wilson and Jean. Thanks guys!


ReplyQuote
stratblue
(@stratblue)
Member
Joined: 2 years ago
Posts: 67
Topic starter  

@eellis

Indeed.


ReplyQuote
stratblue
(@stratblue)
Member
Joined: 2 years ago
Posts: 67
Topic starter  

I'm getting this weird behaviour again. The Octo has been on all day, I seem to remember that this was the case the last time this oddity manifested.


ReplyQuote
Jean Blanc
(@jean)
Member Admin
Joined: 2 years ago
Posts: 19
 

@stratblue

Hi Nick,

I haven't been able to replicate your issue yet... but I'm just starting some extensive testing of some new features so I will keep your issue in mind as I work - it may take me a couple of weeks.

BTW did you do anything to trigger the behaviour ? 

Do update us if you think of anything.

Best,

Jean


ReplyQuote
stratblue
(@stratblue)
Member
Joined: 2 years ago
Posts: 67
Topic starter  
Posted by: @jean

@stratblue

Hi Nick,

I haven't been able to replicate your issue yet... but I'm just starting some extensive testing of some new features so I will keep your issue in mind as I work - it may take me a couple of weeks.

BTW did you do anything to trigger the behaviour ? 

Do update us if you think of anything.

Best,

Jean

The only common factor I noticed was that it was after an all day session, beyond that, no idea. Sorry.


ReplyQuote
Jean Blanc
(@jean)
Member Admin
Joined: 2 years ago
Posts: 19
 

@stratblue

Ok, if the sequencer if rebooted via the red button does the weirdness persist ?

 


ReplyQuote
stratblue
(@stratblue)
Member
Joined: 2 years ago
Posts: 67
Topic starter  
Posted by: @jean

@stratblue

Ok, if the sequencer if rebooted via the red button does the weirdness persist ?

 

Next time it happens I will test it and let you know.


ReplyQuote
Share: